GUIDE How to Enable Thunderbolt 3 Hotplug on macOS

rickymaru

New member
Joined
Jul 27, 2020
Motherboard
Intel CM238
CPU
Intel Core i7-7700HQ 4 x 2.8 - 3.8 GHz, Kaby Lake
Graphics
NVIDIA GeForce GTX 1070 Mobile 8gb
OS X/macOS
10.13.x
Bootloader
  1. Clover (UEFI)
Mac
  1. iMac
Mobile Phone
  1. iOS
In my EFI structure I don't have drivers/UEFI but I have drivers64UEFI. Do I have to put TbtForcePower.efi in there?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
In my EFI structure I don't have drivers/UEFI but I have drivers64UEFI. Do I have to put TbtForcePower.efi in there?
Yes, that's right.
 

Ferz

New member
Joined
Nov 17, 2020
Motherboard
Gigabyte z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
AORUS Radeon RX570 4GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
no any new info? now open core manual? any changes in a few month? I still can't run TB3 hot-plug on my Hackintosh...
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
no any new info? now open core manual? any changes in a few month? I still can't run TB3 hot-plug on my Hackintosh...
Please create a separate thread or provide info.
 

kimbray

New member
Joined
Feb 24, 2021
Motherboard
Aorus X570 Master
CPU
AMD 3950X
Graphics
AMD 5600XT
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac Pro
Mobile Phone
  1. iOS
All, I have the Titan Gigabyte PCI Card working and passing display info to a LG UltraFine 5K on the Mac and windows sides of build (see profile for my build). However the PCI functions of the Titan Ridge PCI card (which are secondary to me) are not seen on the Mac. I have read the guide and I am not really willing to flash the firmware on the Titan Ridge card. I ahve found some easier SSDT links but saw this site had most comprensive and recent feedback on this topic.Net net, is there a way to get PCI funcitonality working with OpenCore 6.6 and Big Sur with minimal forced hacking (I am OK with ACPIs and SSDTs but not really keen on force flashing card. I also have an AMD CPU.. Thanks
 

Similar threads