Battery Indicator is shown but not updating after boot on MacOS BigSur 11.0.1

Rahul12q

New member
Joined
Jun 10, 2021
Motherboard
HP Pavilion 15-bc008tx
CPU
Intel Core i7 6700 HQ (Skylake)
Graphics
1) Intel(R) HD Graphics 530(BIOS Device Name = \_SB.PCI0.GFX0) 2) Nvidia GTX 960m
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
Followed the guide and created full DSDT+SSDT patch , I patched all the common patches recommended for DSDT and SSDT .

But now I lost my brightness and the battery indicator is stuck at 100% forever.

Please help

Attaching PR and EFI
Update : I removed the RTC fix patch and the battery meter is not shown at 100% forever but still the battery meter is not updating when booted.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Update : I removed the RTC fix patch and the battery meter is not shown at 100% forever but still the battery meter is not updating when booted.
RTC SSDT is not required for SKL. Did you applied battery patch to your DSDT?
 

Rahul12q

New member
Joined
Jun 10, 2021
Motherboard
HP Pavilion 15-bc008tx
CPU
Intel Core i7 6700 HQ (Skylake)
Graphics
1) Intel(R) HD Graphics 530(BIOS Device Name = \_SB.PCI0.GFX0) 2) Nvidia GTX 960m
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
RTC SSDT is not required for SKL. Did you applied battery patch to your DSDT?
Yes i did apply the battery patch.

One more thing the macos bigsur is installed on external ssd but i dont think that should be the issue.

Cause i tested catalina first on the external ssd and after everthing worked perfect i installed it on the nvme m.2 internal ssd.

Catalina is running like a real mac.
Bigsur does too but only because of this battery indicator not updating behaviour am not installing in on the internal ssd.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Yes i did apply the battery patch.
Which battery patch?
One more thing the macos bigsur is installed on external ssd but i dont think that should be the issue.

Cause i tested catalina first on the external ssd and after everthing worked perfect i installed it on the nvme m.2 internal ssd.

Catalina is running like a real mac.
Bigsur does too but only because of this battery indicator not updating behaviour am not installing in on the internal ssd.
Installing on external SSD shouldn't be an issue.
 

Rahul12q

New member
Joined
Jun 10, 2021
Motherboard
HP Pavilion 15-bc008tx
CPU
Intel Core i7 6700 HQ (Skylake)
Graphics
1) Intel(R) HD Graphics 530(BIOS Device Name = \_SB.PCI0.GFX0) 2) Nvidia GTX 960m
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
Which battery patch?

Installing on external SSD shouldn't be an issue.
I created my own battery patch using rehabman's guide.

If it works like a charm on catalina. I dont get what is the reason for it to not work on BigSur.


Should i create a hotpatch?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I created my own battery patch using rehabman's guide.

If it works like a charm on catalina. I dont get what is the reason for it to not work on BigSur.


Should i create a hotpatch?
The idea of ACPI patching was not to use a Hotpatch. Hotpatch has few advantages but i always recommend full OEM style patching.

Use "battery_HP-Pavilion-n012tx" patch to your DSDT and disable all the Hotpatch SSDTs except from the OpenCore guide.
 

Rahul12q

New member
Joined
Jun 10, 2021
Motherboard
HP Pavilion 15-bc008tx
CPU
Intel Core i7 6700 HQ (Skylake)
Graphics
1) Intel(R) HD Graphics 530(BIOS Device Name = \_SB.PCI0.GFX0) 2) Nvidia GTX 960m
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
The idea of ACPI patching was not to use a Hotpatch. Hotpatch has few advantages but i always recommend full OEM style patching.

Use "battery_HP-Pavilion-n012tx" patch to your DSDT and disable all the Hotpatch SSDTs except from the OpenCore guide.
I have tried the "battery_HP-Pavilion-n012tx" patch, it is incomplete for my model as 5 registers are still needed to be patched which i did manually replacing them.

When i used the patch as it is the battery meter did not update on the Catalina as well.

But after manually fixing whats left i got the battery working perfectly on Catalina
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have tried the "battery_HP-Pavilion-n012tx" patch, it is incomplete for my model as 5 registers are still needed to be patched which i did manually replacing them.

When i used the patch as it is the battery meter did not update on the Catalina as well.

But after manually fixing whats left i got the battery working perfectly on Catalina
Makes sense. Did you try with ACPIBatteryManager?
 

Rahul12q

New member
Joined
Jun 10, 2021
Motherboard
HP Pavilion 15-bc008tx
CPU
Intel Core i7 6700 HQ (Skylake)
Graphics
1) Intel(R) HD Graphics 530(BIOS Device Name = \_SB.PCI0.GFX0) 2) Nvidia GTX 960m
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android

Rahul12q

New member
Joined
Jun 10, 2021
Motherboard
HP Pavilion 15-bc008tx
CPU
Intel Core i7 6700 HQ (Skylake)
Graphics
1) Intel(R) HD Graphics 530(BIOS Device Name = \_SB.PCI0.GFX0) 2) Nvidia GTX 960m
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
I tried ACPIBatteryManager replacing the SMCBatteryManager but I am getting the same result the battery meter does not update
If BigSur is giving this problem then Monterey will also give same problem right?
 

Similar threads

Forum statistics

Threads
505
Messages
4,680
Members
4,265
Latest member
echozerimad1212