Intel SMBUS patch

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Ok, thank you! Its good.
iStatsMenu have the same situation - no proc temp and fan speed.
In BIOS i have 2 option for temp control - intelligent and static.
When i chose Intelligent - CPU fan have different speed depend cpu temp? when i chose static - fan work on MAX speed all time.
In both cases - no cpu temp or fan speed in tools.



View attachment 3018
Provide BIOS settings. If a CPU FAN is installed, it should show. Make sure you have the same version of SMC kexts.
Also provide EFI, kextcache output.
 

Dmitry 42

New member
Joined
Dec 23, 2020
Motherboard
B360
CPU
i5-8400T
Graphics
UHD 630
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Today i update Opencore to 0.6.6 and latest SMC kext 1.2 (same version sure) - nothing happened.
Bios show me cpu fan speed.
How i can do "kextcache output" ?
And can be problem with config ? Here i have only PlatformInfo-Generic section, in SMBIOS section - fields all blank.


IMG_1055.jpeg
IMG_1056.jpeg
 

Attachments

  • EFI.zip
    25 MB · Views: 7

Dmitry 42

New member
Joined
Dec 23, 2020
Motherboard
B360
CPU
i5-8400T
Graphics
UHD 630
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
kextcache -i/
Executing: /usr/bin/kmutil install --volume-root / --check-rebuild
rebuilding local auxiliary collection
kmutil done
 
Similar threads

Similar threads