EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,858
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Yes I'm aware see the above post
It could be the TB Device itself or the firmware. As per our testing with TB3 and TB4, we got amazing results. Very soon, we'll release a demonstration for TB.
 

Ozma

New member
Joined
Sep 1, 2021
Messages
12
Motherboard
z590 Vision D
CPU
Intel Core i7 10700k
Graphics
5500xt
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
I've investigated a bit
It could be the TB Device itself or the firmware. As per our testing with TB3 and TB4, we got amazing results. Very soon, we'll release a demonstration for TB.

Yes I'd like to see your settings for the Vision D.

I've investigated a bit further and I think Casey's SSDT isn't loading properly. In a detailed bootlog I'm seeing lots of errors after loading CASEY JHL8540. Lots of warnings like this:

ACPI Warning:
Unsupported module-level executable opcode 0x70 at table offset 0x45B07

I'm not skilled enough to diagnose this issue but curious what you think. Full bootlog attached.
 

Attachments

  • bootlog.txt
    126.3 KB · Views: 77

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,858
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I've investigated a bit


Yes I'd like to see your settings for the Vision D.

I've investigated a bit further and I think Casey's SSDT isn't loading properly. In a detailed bootlog I'm seeing lots of errors after loading CASEY JHL8540. Lots of warnings like this:

ACPI Warning:
Unsupported module-level executable opcode 0x70 at table offset 0x45B07

I'm not skilled enough to diagnose this issue but curious what you think. Full bootlog attached.
Unfortunately, i no longer have that Motherboard with me. That doesn't matters. A correct sign of a complete loading of SSDT can be checked by IOReg, where the address changes to DSB0 and NHI0 starts loading.
 

Ozma

New member
Joined
Sep 1, 2021
Messages
12
Motherboard
z590 Vision D
CPU
Intel Core i7 10700k
Graphics
5500xt
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
Yes, it works.

Considering there are lots of threads all over in internet saying that it does not, including CaseySJ, we can assume this is not true until proven otherwise.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,858
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Considering there are lots of threads all over in internet saying that it does not, including CaseySJ, we can assume this is not true until proven otherwise.
Everyone has their own research and way of implementation. Before we figured out the Antelope thingy, no one managed to do this even on the new macOS version, but now it is possible and we are the first to reveal the idea, not others. For most of them, it was not possible but it was possible for us. Z590 Vision D has Hotplug working, verified by us, without any issue. MSI Z590 UNIFY has a similar result. We already added MSI Z590I UNIFY test results in the first post of this thread. It might be possible for us to publish the test results for GIGABYTE Z590 VISION D ;)

Of course, due to the TB4 nature, it's not possible to have Hotplug with a few PCIe capable TB Devices due to the NHI driver not loading. We continue to test several systems, work on several projects and that is why it is not always possible for us to provide such proof over the internet.
 

phyd

New member
Joined
Jan 22, 2022
Messages
5
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7940X
Graphics
RX 6900XT (XTXH)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Heya @EliteMacx86

Trying to implement your hot plug on my Osx 12.1 Monterey install.

I currently have TB working on cold boot up. Can't quite get the hot plug working as per your guide yet.

It's a Thunderbolt EX3 card installed in slot#4 of Asus X299 Prime Deluxe MB - have uploaded screenshot of IOReg.

Have also attached zipped OC folder from EFI.

Any help is appreciated.
 

Attachments

  • Screen Shot 2022-01-22 at 2.39.35 pm.png
    Screen Shot 2022-01-22 at 2.39.35 pm.png
    167.4 KB · Views: 44
  • OC.zip
    10.3 MB · Views: 41

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,858
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Heya @EliteMacx86

Trying to implement your hot plug on my Osx 12.1 Monterey install.

I currently have TB working on cold boot up. Can't quite get the hot plug working as per your guide yet.

It's a Thunderbolt EX3 card installed in slot#4 of Asus X299 Prime Deluxe MB - have uploaded screenshot of IOReg.

Have also attached zipped OC folder from EFI.

Any help is appreciated.
Not a TB 4 Card. Create a separate thread or reply to the TB 3 HotPlug thread.
 

sushiintokyo

New member
Joined
Aug 30, 2022
Messages
15
Motherboard
Z690 gigabyte UD DDR4
CPU
12900k
Graphics
Rx 580
OS X/macOS
12.0.x
Bootloader
  1. Clover (Legacy)
  2. OpenCore
Mac
  1. iMac Pro
Mobile Phone
  1. iOS
Seems I have a problem I don't hardware right now to test but looks like thunderbolt controler not installed
 

Attachments

  • Capture d’écran 2022-08-30 à 22.07.32.png
    Capture d’écran 2022-08-30 à 22.07.32.png
    507.6 KB · Views: 4
  • Capture d’écran 2022-08-30 à 22.07.22.png
    Capture d’écran 2022-08-30 à 22.07.22.png
    150.8 KB · Views: 3
  • Capture d’écran 2022-08-30 à 21.47.21.png
    Capture d’écran 2022-08-30 à 21.47.21.png
    112.8 KB · Views: 3
  • Capture d’écran 2022-08-30 à 21.47.15.png
    Capture d’écran 2022-08-30 à 21.47.15.png
    117.5 KB · Views: 3
  • Capture d’écran 2022-08-30 à 21.46.43.png
    Capture d’écran 2022-08-30 à 21.46.43.png
    56.7 KB · Views: 3
  • Capture d’écran 2022-08-30 à 21.46.28.png
    Capture d’écran 2022-08-30 à 21.46.28.png
    84.1 KB · Views: 3
  • Capture d’écran 2022-08-30 à 22.24.46.png
    Capture d’écran 2022-08-30 à 22.24.46.png
    93.8 KB · Views: 4

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,858
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Seems I have a problem I don't hardware right now to test but looks like thunderbolt controler not installed
As per the IOReg, the TB4 is working and the HotPlug is implemented correctly. The reason you don't see any TB information in System Report>Thunderbolt is because it lacks Bus activation which is absolutely normal for stock firmware.
 

sushiintokyo

New member
Joined
Aug 30, 2022
Messages
15
Motherboard
Z690 gigabyte UD DDR4
CPU
12900k
Graphics
Rx 580
OS X/macOS
12.0.x
Bootloader
  1. Clover (Legacy)
  2. OpenCore
Mac
  1. iMac Pro
Mobile Phone
  1. iOS
thanks and do you think i can use Maple ridge for X299X designare 10G ?
 

Forum statistics

Threads
749
Messages
7,925
Members
6,855
Latest member
Breakthru81