Titan Ridge w/ no THB_C Header (PR zip included)

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thank you so much. Yeah I'm using them separately, I havent been able to get either working. This is with the Titan Ridge 2.0. I cant believe its showing up as a RAID controller and still not available :/ thank you again!
Incomplete PR files attached. IOReg is missing.
 

TripleYoThreat

New member
Joined
Mar 23, 2021
Motherboard
MSI Z97 Gaming 7
CPU
i5-4690k
Graphics
Sapphire Vega 56
OS X/macOS
10.14.x
Bootloader
  1. Clover (UEFI)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I ended up just swapping for the ProArt Z490 Creator, in the interest of time. Lost the white board but whatever. I was also trying to get two more TB3 ports added to the ProArt but that didn't work. even with flashed ROMs... I wouldnt say I gave up as much as I made a time centric decision lol
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I ended up just swapping for the ProArt Z490 Creator, in the interest of time. Lost the white board but whatever. I was also trying to get two more TB3 ports added to the ProArt but that didn't work. even with flashed ROMs... I wouldnt say I gave up as much as I made a time centric decision lol
For now, we've been able to achieve 3xTitan Ridge, with total 6 ports of TB with most of the function. Is Z490 Creator working as indented?
 

TripleYoThreat

New member
Joined
Mar 23, 2021
Motherboard
MSI Z97 Gaming 7
CPU
i5-4690k
Graphics
Sapphire Vega 56
OS X/macOS
10.14.x
Bootloader
  1. Clover (UEFI)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
For now, we've been able to achieve 3xTitan Ridge, with total 6 ports of TB with most of the function. Is Z490 Creator working as indented?
Yessir! Perfectly! With Hotplug, cold boot, boot with no devices attached then plugging in. Only thing I haven't tested is sleep with drive mounted. You can add it to the success / tested list if you'd like. Using "G-Speed Shuttle RAID Thunderbolt 3". No drivers needed worked perfectly.

As far as the Titan Ridges...I'm utterly confused as I had tried damn near everything I saw online. I tried a flashed Titan Ridge & Alpine Ridge, I used the 3/5 pin short, and I used the DTPG.aml as well as modified and made the correct one using hackindrom. It would show up in system report every time, and even show the G-Speed, but not mount. I wonder if an audio interface or different device would have worked.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Yessir! Perfectly! With Hotplug, cold boot, boot with no devices attached then plugging in. Only thing I haven't tested is sleep with drive mounted. You can add it to the success / tested list if you'd like. Using "G-Speed Shuttle RAID Thunderbolt 3". No drivers needed worked perfectly.
Perfect. Provide the screenshots+IOReg+TB Device models tested. It will be added under the list.
As far as the Titan Ridges...I'm utterly confused as I had tried damn near everything I saw online. I tried a flashed Titan Ridge & Alpine Ridge, I used the 3/5 pin short, and I used the DTPG.aml as well as modified and made the correct one using hackindrom. It would show up in system report every time, and even show the G-Speed, but not mount. I wonder if an audio interface or different device would have worked.
Well, in few case, that's normal. It also depends on the firmware you're using. It also depends on the installation and setup. We've tested a lot of motherboards from Z370 to X299X.
 

TripleYoThreat

New member
Joined
Mar 23, 2021
Motherboard
MSI Z97 Gaming 7
CPU
i5-4690k
Graphics
Sapphire Vega 56
OS X/macOS
10.14.x
Bootloader
  1. Clover (UEFI)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Perfect. Provide the screenshots+IOReg+TB Device models tested. It will be added under the list.
They're off with clients :/
I don't think I grabbed an IOReg on the ProArt Z490 Creator either, since it was working all fine.
Well, in few case, that's normal. It also depends on the firmware you're using. It also depends on the installation and setup. We've tested a lot of motherboards from Z370 to X299X.
any recommended ones? I tried Elias v23 and v50
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
They're off with clients :/
I don't think I grabbed an IOReg on the ProArt Z490 Creator either, since it was working all fine.
Oh, damn. If you want, grab it and add it to the thread so users can have more information for test results.

any recommended ones? I tried Elias v23 and v50
DSM2 and NVM33.
 

TripleYoThreat

New member
Joined
Mar 23, 2021
Motherboard
MSI Z97 Gaming 7
CPU
i5-4690k
Graphics
Sapphire Vega 56
OS X/macOS
10.14.x
Bootloader
  1. Clover (UEFI)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Oh, damn. If you want, grab it and add it to the thread so users can have more information for test results.
Both ProArt Creator builds are with clients so I don't have access to them anymore :( But yeah, everything works super smooth with onboard compared to AIC.

DSM2 and NVM33.
Yeah interestingly I think it's problematic when the board has onboard TB3. but who knows, I'm definitely wrong there because I remember someone on tonymac got an AIC added WITH onboard TB3
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Both ProArt Creator builds are with clients so I don't have access to them anymore :( But yeah, everything works super smooth with onboard compared to AIC.
Ah ok. Sounds good. Unfortunately, i would not be able to add this info to the thread without IOReg and screenshots.
Yeah interestingly I think it's problematic when the board has onboard TB3. but who knows, I'm definitely wrong there because I remember someone on tonymac got an AIC added WITH onboard TB3
We've never tested with case like yours. But it would be interesting to try it. Built-In TB3+AIC.
 

Similar threads

Forum statistics

Threads
468
Messages
4,330
Members
4,069
Latest member
felipe.sntr