Titan Ridge Thunderbolt on Hackintosh

PTuser

New member
Joined
Aug 5, 2020
Motherboard
x79-up4
CPU
17-3930
Graphics
radeon wx4100
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mobile Phone
  1. iOS

Reputation:

Hi - I am running Catalina 10.15.6 and have installed a titan ridge card flashed with dsm firmware on my non header machine. with the modded tb header pin fix. All TB devices I have are working except for the most important one, which is a Focusrite red range thunderbolt audio interface. This device is seen in the system in sys profiler and I have green Thunderbolt lights on the device . It can be controlled by thunderbolt but it wont work with system audio. I tried this device in a mac mini with tb2 and it worked fine so something is not right in my implementation. Im looking for some help to find the solution. I took IO reg screenshots of the working mac mini and my hackintosh and there are some differences however Im not clear on how to edit SSDT or other solutions
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

Reputation:

Hi - I am running Catalina 10.15.6 and have installed a titan ridge card flashed with dsm firmware on my non header machine. with the modded tb header pin fix. All TB devices I have are working except for the most important one, which is a Focusrite red range thunderbolt audio interface. This device is seen in the system in sys profiler and I have green Thunderbolt lights on the device . It can be controlled by thunderbolt but it wont work with system audio. I tried this device in a mac mini with tb2 and it worked fine so something is not right in my implementation. Im looking for some help to find the solution. I took IO reg screenshots of the working mac mini and my hackintosh and there are some differences however Im not clear on how to edit SSDT or other solutions
Start here:
 

PTuser

New member
Joined
Aug 5, 2020
Motherboard
x79-up4
CPU
17-3930
Graphics
radeon wx4100
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mobile Phone
  1. iOS

Reputation:

Start here:
Hi - thanks for your message - I did read that - I thought this may be a bit different given the device is seen hence the post - however I will post my findings on that thread....
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

Reputation:

Hi - thanks for your message - I did read that - I thought this may be a bit different given the device is seen hence the post - however I will post my findings on that thread....
Sure.
 

Similar threads

Trending Threads

Latest posts

Forum statistics

Threads
456
Messages
4,217
Members
3,963
Latest member
Gabik