betovelandia

New member
Joined
Jul 15, 2021
Motherboard
Apple - Mac Pro 5.1 Motherboard
CPU
2 x 2.4 GHz Quad-Core Intel Xeon
Graphics
Radeon RX 480 4 GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac Pro
Mobile Phone
  1. iOS

betovelandia

New member
Joined
Jul 15, 2021
Motherboard
Apple - Mac Pro 5.1 Motherboard
CPU
2 x 2.4 GHz Quad-Core Intel Xeon
Graphics
Radeon RX 480 4 GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac Pro
Mobile Phone
  1. iOS

jeam25

New member
Joined
Jul 15, 2021
Motherboard
Arock Z590 Steel Legend
CPU
i9 10900 Comet Lake
Graphics
Radeon Pulse 580
OS X/macOS
10.15.x
Bootloader
  1. OpenCore
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hi again understood , sorry well, here we go again. My current issue is this. Im trying to make a custom ssdt according to the tutorial but I can't boot with it. The cuputer is stuck at start to load the progress bar at apple logo screen.

I got a pre build SSDT that work BUT the OS see my TB devices AFTER reboot. Attached all the files at once . Thanks

I just only want a SSDT that I can boot my TB devices at once without having to reboot in order to get them recognized.

1. Gygabyte GC- Alpine Ridge AIC
2. TB header available
3. Limited Bios setting sending a photo of them on next reply
4. Asrock Z590 Steel Leyend
5. i9 Comet Lake 10900
6. Catalina 10.15.7
 

Attachments

  • Bios settings.jpg
    Bios settings.jpg
    1.9 MB · Views: 9
  • efi-zip.3575.zip
    3.1 MB · Views: 8
  • Io Reg.zip
    950.1 KB · Views: 5
  • PCI Devices.zip
    844.2 KB · Views: 6
  • ssdt-tb3-hackindrom-aml-zip.3576.zip
    1.9 KB · Views: 8

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I was told the version is nvm23
That should still work. When the device detects in the IOReg, did you got any Thunderbolt information under System Report>Thunderbolt?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi again understood , sorry well, here we go again. My current issue is this. Im trying to make a custom ssdt according to the tutorial but I can't boot with it. The cuputer is stuck at start to load the progress bar at apple logo screen.

I got a pre build SSDT that work BUT the OS see my TB devices AFTER reboot. Attached all the files at once . Thanks

I just only want a SSDT that I can boot my TB devices at once without having to reboot in order to get them recognized.

1. Gygabyte GC- Alpine Ridge AIC
2. TB header available
3. Limited Bios setting sending a photo of them on next reply
4. Asrock Z590 Steel Leyend
5. i9 Comet Lake 10900
6. Catalina 10.15.7
That's because you're using a wrong SSDT which is paired with your EFI. Remove SSDT-Z370-TB3HP and use the other SSDT which you have attached.
 

jeam25

New member
Joined
Jul 15, 2021
Motherboard
Arock Z590 Steel Legend
CPU
i9 10900 Comet Lake
Graphics
Radeon Pulse 580
OS X/macOS
10.15.x
Bootloader
  1. OpenCore
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Well don't know what to say. Ive tried the one before and for some reason it got stuck at the apple logo ! Well now it is working :) Thank you very much !
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Well don't know what to say. Ive tried the one before and for some reason it got stuck at the apple logo ! Well now it is working :) Thank you very much !
Great!
 

WilliamBrantree

New member
Joined
Jul 19, 2021
Motherboard
Gigabyte Designare Z390
CPU
i99700K
Graphics
Radeon 5700X
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi Everyone! I have followed the instructions to a T and my Gigabyte Designare Z390 is still not showing the the thunderbolt ports. I have also attached the SSDT and config.plist file if someone could kindly review it and let me know if something needs to be changed.
Screen Shot 2021-07-19 at 3.10.32 PM.png
 

Attachments

  • SSDT-TB3-HackinDROM.aml.zip
    1.6 KB · Views: 4
  • config.plist.zip
    4 KB · Views: 5

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi Everyone! I have followed the instructions to a T and my Gigabyte Designare Z390 is still not showing the the thunderbolt ports. I have also attached the SSDT and config.plist file if someone could kindly review it and let me know if something needs to be changed. View attachment 3601
Incomplete PR files attached.
 

Forum statistics

Threads
516
Messages
4,880
Members
4,418
Latest member
canvn2000