[SOLVED] install Catalina on ASUS k571GT Intel® Core™ i7 9750H - INTEL UHD 630

promisedSavior

New member
Joined
Jun 9, 2020
Messages
20
Motherboard
ASUS VivoBook K571GT Laptop
CPU
Intel® Core™ i7 9750H
Graphics
Intel UHD 630, NVIDIA GeForce GTX 1650
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mobile Phone
  1. Android
Hi, first thank you for your clean guides.

I tried to create a boot USB flash with Clover UEFI to install Catalina, here is what I did :
1. set BIOS Setting :
  • first Set to Default setting.
  • Network Stack = Disabled.
  • Secure Boot = Disabled.
  • SATA Mode = AHCI.
  • VT-d Option = Disabled
  • Intel Virtualization Technology = Enabled
  • Fast Boot = Disabled
2. copy install file of Catalina in USB flash as mentioned in guide-how-to-boot-macos-installer-on-laptops
3. Installed Clover_r5118.pkg UEFI mode on USB flash
4. Placing required kexts in the EFI partition
5. Use config_UHD630 from here : RehabMan OS-X-Clover-Laptop-Config
TEST the USB but it stuck on loading Clover logo in Scan entries
6. Then I edit config.plist as said in here : coffee lake CPU config.plist
Test the USB but it stuck on loading Clover logo in Scan entries AGAIN

I installed mac OS Catalina on another ASUS Laptop (K556UQ model) Before but Never stuck in this state and I don't know where this error come from, search in google but can't find a way to pass it.

I'm waiting for your suggestions, THANKS

also i tried to attach my EFI folder (2.3 Mb - theme folder excluded) but it says
  • The uploaded file is too large for the server to process
    so I Upload it here : google drive EFI.zip
 
Last edited:

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,303
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi, first thank you for your clean guides.

I tried to create a boot USB flash with Clover UEFI to install Catalina, here is what I did :
1. set BIOS Setting :
  • first Set to Default setting.
  • Network Stack = Disabled.
  • Secure Boot = Disabled.
  • SATA Mode = AHCI.
  • VT-d Option = Disabled
  • Intel Virtualization Technology = Enabled
  • Fast Boot = Disabled
2. copy install file of Catalina in USB flash as mentioned in guide-how-to-boot-macos-installer-on-laptops
3. Installed Clover_r5118.pkg UEFI mode on USB flash
4. Placing required kexts in the EFI partition
5. Use config_UHD630 from here : RehabMan OS-X-Clover-Laptop-Config
TEST the USB but it stuck on loading Clover logo in Scan entries
6. Then I edit config.plist as said in here : coffee lake CPU config.plist
Test the USB but it stuck on loading Clover logo in Scan entries AGAIN

I installed mac OS Catalina on another ASUS Laptop (K556UQ model) Before but Never stuck in this state and I don't know where this error come from, search in google but can't find a way to pass it.

I'm waiting for your suggestions, THANKS

also i tried to attach my EFI folder (2.3 Mb - theme folder excluded) but it says
  • The uploaded file is too large for the server to process
    so I Upload it here : google drive EFI.zip
If you need support from this forum, you must follow the guides available here.

Here are some of the issues.
  • The config.plist is not as per the guide. Use the config.plist from the guide on this forum.
  • BIOS directory is only meant for Legacy BIOS. Remove it.
  • You're having duplicate AptioMemoryFix drivers. Remove "AptioMemoryFix-64.efi".

HInt: The reason why you're stuck at scan entries is due to NVRAM. Install "EmuVariableUefi-64.efi".
 

promisedSavior

New member
Joined
Jun 9, 2020
Messages
20
Motherboard
ASUS VivoBook K571GT Laptop
CPU
Intel® Core™ i7 9750H
Graphics
Intel UHD 630, NVIDIA GeForce GTX 1650
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mobile Phone
  1. Android
Thanks, OK I use config.plist as mentioned in guide and did what you said. with "EmuVariableUefi-64.efi" I could load clover (y)
after choose "Boot macOS Install", after a while screen glitched with a white 🚫 on it:
1.jpg


last line of debug file is :
Code:
999:946  1:500  Using load options 'boot.efi dart=0 nv_disable=1 -disablegfxfirmware -cdfon -igfxnohdmi -v debug=0x100 keepsyms=1 '
and I attached debug file.
Another question is that I don't know am I need to Patch SSDT for disabling the Discrete Graphics now or after complete install ?
 

Attachments

  • debug.log.zip
    10.5 KB · Views: 155
  • config.plist.zip
    2.9 KB · Views: 241
Last edited:

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,303
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thanks, OK I use config.plist as mentioned in guide and did what you said. with "EmuVariableUefi-64.efi" I could load clover (y)
Great.
after choose "Boot macOS Install", after a while screen glitched with a white 🚫 on it so I cant see what was the last line said.
USB related. Add Catalina port limit patch and you should be good to go.
 

promisedSavior

New member
Joined
Jun 9, 2020
Messages
20
Motherboard
ASUS VivoBook K571GT Laptop
CPU
Intel® Core™ i7 9750H
Graphics
Intel UHD 630, NVIDIA GeForce GTX 1650
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mobile Phone
  1. Android
Great.

USB related. Add Catalina port limit patch and you should be good to go.
I added these two in kernel and kext patches :

Name*: com.apple.iokit.IOUSBHostFamily
Find*: 83FB0F0F
Replace*: 83FB3F0F

Name* com.apple.driver.usb.AppleUSBXHCI
Find*: 83F90F0F
Replace*: 83F93F0F

still same problem ...
 

promisedSavior

New member
Joined
Jun 9, 2020
Messages
20
Motherboard
ASUS VivoBook K571GT Laptop
CPU
Intel® Core™ i7 9750H
Graphics
Intel UHD 630, NVIDIA GeForce GTX 1650
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mobile Phone
  1. Android
I added these two in kernel and kext patches :

Name*: com.apple.iokit.IOUSBHostFamily
Find*: 83FB0F0F
Replace*: 83FB3F0F

Name* com.apple.driver.usb.AppleUSBXHCI
Find*: 83F90F0F
Replace*: 83F93F0F

still same problem ...
find the problem :
No EC0 rename is added. Add EC0 rename.
and now I'm in installer, more info will be added soon as I go forward ...
 

promisedSavior

New member
Joined
Jun 9, 2020
Messages
20
Motherboard
ASUS VivoBook K571GT Laptop
CPU
Intel® Core™ i7 9750H
Graphics
Intel UHD 630, NVIDIA GeForce GTX 1650
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mobile Phone
  1. Android
Hi, I'm trying to copy iasl in /usr/bin
the SIP is disabled in config.plist (image attached) but bin folder is locked, in Get info Lock checkbox is disable, I can not add write permission for my user so I can't copy iasl in bin folder :(

and from terminal when I ran sudo cp iasl /usr/bin it says :
cp: /usr/bin/iasl: Read-only file system

I googled it but no success, Where is my problem ?

Screen Shot 1399-03-22 at 12.43.55.png
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,303
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I added these two in kernel and kext patches :

Name*: com.apple.iokit.IOUSBHostFamily
Find*: 83FB0F0F
Replace*: 83FB3F0F

Name* com.apple.driver.usb.AppleUSBXHCI
Find*: 83F90F0F
Replace*: 83F93F0F

still same problem ...
Make sure XHCI Handoff is Enabled in your BIOS.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,303
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
find the problem :
No EC0 rename is added. Add EC0 rename.
and now I'm in installer, more info will be added soon as I go forward ...
Yes, EC0 patch is required for Catalina. I'll update the guides soon. :)
 
  • Like
Reactions: promisedSavior

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,303
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi, I'm trying to copy iasl in /usr/bin
the SIP is disabled in config.plist (image attached) but bin folder is locked, in Get info Lock checkbox is disable, I can not add write permission for my user so I can't copy iasl in bin folder :(

and from terminal when I ran sudo cp iasl /usr/bin it says :
cp: /usr/bin/iasl: Read-only file system

I googled it but no success, Where is my problem ?

View attachment 2534
Catalina has read only feature. @Cyberdevs has already done a great job.
Check his work here:
 

Similar threads

Forum statistics

Threads
631
Messages
6,838
Members
5,565
Latest member
weto