Intel HD4000 macOS Monterey 12.6 - Laptop's internal display not working, External monitor is working - Dell inspiron 15R SE ( 7520)

abdulahath

Member
Joined
Sep 19, 2022
Messages
31
Motherboard
Dell Inspiron 15R SE 7520
CPU
Intel Core i5 3230M / Intel Ivy Bridge/HM77
Graphics
Intel HD Graphics 4000 with AMD Radeon HD 7730M 1366x768
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
Dear Admin,

I hackintoshed my Dell laptop inpiron 15R SE (7520) with macos Monterey 12.6 from Olarilla's website.
After the installation of Monterey 12.6 , initially my system detected only 4MB of VGA of INTEL HD 4000.

Therefore i installed the application "https://github.com/chris1111/Patch-HD4000-Monterey " .

before the installation i did the below settings.
1. csrutil authenticated-root disable
2. disabled gate keeper
3. enable auto login
4. Using the OC Configurator 0.8.4 csr-active-config ➤ EF0F0000 , SecureBootModel ➤ Disabled , PlatformInfo ➤ MacBookPro13,1
5. Used the boot args " -v alcid=3 watchdog=0 igfxonln=1 -no_compat_check -revsbvmm keepsyms=1 amfi_get_out_of_my_way=1"

After the installation of Patch-HD4000-Monterey my laptop has restarted --> After showing the verbose texts for sometime and my laptop display went to Dark gray screen with many thin horizontal lines that will be clearly seen if you look closely. But i understood that my laptop(Hackintosh) still working in background.
Therefore i connected an external Monitor. It worked and got the display working with the graphics acceleration and macOS detected the intel HD4000 1536MB. Minimize animations are working great.

It is strange that, my internal display is not working with the Monterey after the Patch-HD4000-Monterey. External monitor is working.
Please help me to fix this issue of internal laptop screen. I couldn't find any related issues on internet and forums.


Thanks in Advance


For you information Please refer my EFI folder at "https://github.com/abdulahath/EFI_monterey-12.6.git"
 

Attachments

  • Photos of Issue.zip
    664 KB · Views: 0

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,861
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Dear Admin,

I hackintoshed my Dell laptop inpiron 15R SE (7520) with macos Monterey 12.6 from Olarilla's website.
After the installation of Monterey 12.6 , initially my system detected only 4MB of VGA of INTEL HD 4000.

Therefore i installed the application "https://github.com/chris1111/Patch-HD4000-Monterey " .

before the installation i did the below settings.
1. csrutil authenticated-root disable
2. disabled gate keeper
3. enable auto login
4. Using the OC Configurator 0.8.4 csr-active-config ➤ EF0F0000 , SecureBootModel ➤ Disabled , PlatformInfo ➤ MacBookPro13,1
5. Used the boot args " -v alcid=3 watchdog=0 igfxonln=1 -no_compat_check -revsbvmm keepsyms=1 amfi_get_out_of_my_way=1"

After the installation of Patch-HD4000-Monterey my laptop has restarted --> After showing the verbose texts for sometime and my laptop display went to Dark gray screen with many thin horizontal lines that will be clearly seen if you look closely. But i understood that my laptop(Hackintosh) still working in background.
Therefore i connected an external Monitor. It worked and got the display working with the graphics acceleration and macOS detected the intel HD4000 1536MB. Minimize animations are working great.

It is strange that, my internal display is not working with the Monterey after the Patch-HD4000-Monterey. External monitor is working.
Please help me to fix this issue of internal laptop screen. I couldn't find any related issues on internet and forums.


Thanks in Advance


For you information Please refer my EFI folder at "https://github.com/abdulahath/EFI_monterey-12.6.git"
Using of OCLP is preferred.

Attach your EFI to check further.
 

abdulahath

Member
Joined
Sep 19, 2022
Messages
31
Motherboard
Dell Inspiron 15R SE 7520
CPU
Intel Core i5 3230M / Intel Ivy Bridge/HM77
Graphics
Intel HD Graphics 4000 with AMD Radeon HD 7730M 1366x768
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
initially i used the OCLP and got into the same grey screen ( hard disk is worked in background). at that time, i didn't connected the external monitor and checked if it's working.

After the OCLP grey screen , i did another clean install and did the process mentioned in my question using Patch-HD4000-Monterey . Then only I found out that my External monitor is working, but internal screen not working.

My EFI is 40MB , Therefore i couldn't attach. Can you please check my EFI uploaded to
github -https://github.com/abdulahath/EFI_monterey-12.6.git
we transfer - https://we.tl/t-gpsAs5w0MD


Just now i tried that , instead of using igfxonln=1 , if i used -igfxvesa . Then it booted without the acceleration and Laptop internal screen is worked and the System is showing 4MB only.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,861
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
initially i used the OCLP and got into the same grey screen ( hard disk is worked in background). at that time, i didn't connected the external monitor and checked if it's working.
With APFS File System, SSD is recommended.
Just now i tried that , instead of using igfxonln=1 , if i used -igfxvesa . Then it booted without the acceleration and Laptop internal screen is worked and the System is showing 4MB only.
Your configuration is not as per the guide. You cannot expect it to work.

Start here:
 
  • Like
Reactions: abdulahath

abdulahath

Member
Joined
Sep 19, 2022
Messages
31
Motherboard
Dell Inspiron 15R SE 7520
CPU
Intel Core i5 3230M / Intel Ivy Bridge/HM77
Graphics
Intel HD Graphics 4000 with AMD Radeon HD 7730M 1366x768
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
Yes i'm using the SSD Drive to install Monterey.

I couldn't found the EFI folder for my Laptop model inspiron 15R SE 7520. Therefore, i used the available ivybridge EFI from a site. Please advice me, which EFI folder should i use , that is closest to my laptop.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,861
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Yes i'm using the SSD Drive to install Monterey.

I couldn't found the EFI folder for my Laptop model inspiron 15R SE 7520. Therefore, i used the available ivybridge EFI from a site. Please advice me, which EFI folder should i use , that is closest to my laptop.
Using someone's EFI is not advised. You should start with the guide I linked above.
 
  • Like
Reactions: abdulahath

abdulahath

Member
Joined
Sep 19, 2022
Messages
31
Motherboard
Dell Inspiron 15R SE 7520
CPU
Intel Core i5 3230M / Intel Ivy Bridge/HM77
Graphics
Intel HD Graphics 4000 with AMD Radeon HD 7730M 1366x768
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
Thank you for your advise. I'am going to start with the guide you have linked.
If i'm getting into any problems, i'll keep you posted.

Thanks again for your time and consideration.
 
  • Like
Reactions: EliteMacx86

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,861
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thank you for your advise. I'am going to start with the guide you have linked.
If i'm getting into any problems, i'll keep you posted.

Thanks again for your time and consideration.
Great. Following the guide will help you not only get a bunch of issues fixed but you'll also get to know about the process.
 
  • Love
Reactions: abdulahath

abdulahath

Member
Joined
Sep 19, 2022
Messages
31
Motherboard
Dell Inspiron 15R SE 7520
CPU
Intel Core i5 3230M / Intel Ivy Bridge/HM77
Graphics
Intel HD Graphics 4000 with AMD Radeon HD 7730M 1366x768
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android
Hi ,

I have been preparing the EFI as per the instructions mentioned in the guide you have provided. I've finished the things mentioned in the article "#post-7590 - Setting up config.plist" .

Then the next post "#post-7591 - Selecting a config.plist File" is confusing to me. It says
We've already created a separate thread on configuring your config.plist to boot the installer. Depending on your hardware, configure the config.plist according to the guide. Depending on the Platform and CPU you have, select the appropriate config.plist building guide.

But there is no reference to the separate thread to follow up with. The guide links also not mentioned as per the attached screenshot.

Please advise me to go further from this.
Thanks in Advance
 

Attachments

  • guide links not found.jpg
    guide links not found.jpg
    69.6 KB · Views: 1

abdulahath

Member
Joined
Sep 19, 2022
Messages
31
Motherboard
Dell Inspiron 15R SE 7520
CPU
Intel Core i5 3230M / Intel Ivy Bridge/HM77
Graphics
Intel HD Graphics 4000 with AMD Radeon HD 7730M 1366x768
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. Android

Attachments

  • seperate guide.jpg
    seperate guide.jpg
    125.3 KB · Views: 1

Forum statistics

Threads
749
Messages
7,931
Members
6,855
Latest member
Breakthru81