EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Work! But when i restart stop connected my Apollo twin x.I restarted again and now connect but without sound :(.Sometimes the keyboard and mouse stop working or i think mac os x Big sur freeze.
Here it is my PR. Other problem the Wifi stoped working after 5 min.
This thread is related to TB HotPlug only. If you need help in other areas, create a separate thread.
 

rmihai81

New member
Joined
May 11, 2022
Messages
17
Motherboard
Z390 Aorus Elite
CPU
i7 8700k
Graphics
5700xt
OS X/macOS
11.0.x
Bootloader
  1. Clover (Legacy)
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I thought that was all i need to work Apollo twin x.But what is HotPlug?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I thought that was all i need to work Apollo twin x.But what is HotPlug?
HotPlug means connecting and using the Device without the need for a restart.
 

rmihai81

New member
Joined
May 11, 2022
Messages
17
Motherboard
Z390 Aorus Elite
CPU
i7 8700k
Graphics
5700xt
OS X/macOS
11.0.x
Bootloader
  1. Clover (Legacy)
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Did you mean to Titan ridge thunderbolt.For Apollo twin x i need other tread.Thank you for your help.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Did you mean to Titan ridge thunderbolt.For Apollo twin x i need other tread.Thank you for your help.
No. What's wrong with Apollo Twin X?
 

rmihai81

New member
Joined
May 11, 2022
Messages
17
Motherboard
Z390 Aorus Elite
CPU
i7 8700k
Graphics
5700xt
OS X/macOS
11.0.x
Bootloader
  1. Clover (Legacy)
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Not all the time connect when i make a restart.Sometimes connect but not sound.Sometimes big sur freeze and wifi not work.Before i make this operations all work perfect.(except the thunderbolt).Need to put back the old DSDT in Efi?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Not all the time connect when i make a restart.Sometimes connect but not sound.Sometimes big sur freeze and wifi not work.Before i make this operations all work perfect.(except the thunderbolt).Need to put back the old DSDT in Efi?
You should consider switching to OpenCore and creating your configuration again to resolve issues. I suggest you to create a separate thread for the freezing issues you have.
 

rmihai81

New member
Joined
May 11, 2022
Messages
17
Motherboard
Z390 Aorus Elite
CPU
i7 8700k
Graphics
5700xt
OS X/macOS
11.0.x
Bootloader
  1. Clover (Legacy)
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I'm tired. Maybe I'll try another day.Thank you for the support.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Recently I tested something that works.
I bought a Wimaxit1560CTV2 touch screen which has HDMI input but also USB-C.
It worked over HDMI or USB-C (except for touch) via UHD 630 and my 32" Philips 325E curved main screen works with my Radeon RX570.

I wanted to connect the 15.6" Wimaxit screen via USB-C to have fewer cables and lower consumption.

Only my Asus thunderbolt EX 3 card (alpine ridge NVM 26) has only one thunderbolt port and I needed 2, 1 for the USB-C screen and 1 for my Antelope DS8SC.
So I found a used Asus thunderboltEX 3 TR card (titan ridge NVM 56) with 2 thunderbolt USB-C ports.

The problem is that my Asus prime Z390-A motherboard is not given by Asustek as compatible with this thunderbolt card!!.

So I replaced my old TBEX 3 card with the TBEX3 TR model but without being able to connect the internal TBC cable because it has 14+1 pin TBC and my motherboard only 5 pin TBC!!.
I also didn't connect the internal 6 pin connector for the charging power supply.
I only connect the internal USB2 cable.
I just modified the bios to indicate 2 thunderbolt ports.
The card like the old one was located on PCI port 3.

Under W10 everything worked but under Catalina the thunderbolt Asus TR card is recognized under Hackintool as JHL 7540 but only the USB-C screen and my main screen worked.
Impossible to recognize my Antelope card whatever the different configurations I tried !!.
And then as a last hope, I changed my PCI port thunderbolt card and put it in PCI 2.
Modified the bios somewhat, deleted my "thunderbolt hackindrom ssdt" in acpi/patched and there everything worked, the USB-C screen ert my Antelope card.

Only the touch function of the USB-C screen does not work!.
Or rather it works but badly, like a second mouse with only one cursor for both!. The touchscreen is badly activated but I don't see how to do it..?
Maybe by flashing a modified firmware ??

To sum up, the Asus thunderboltEX 3 TR card works with the Asus prime Z390-A motherboard but without connecting the internal TBC and placing it on PCI port 2.


If interested I will post my EFI and my ioreg and the photographs of the bios modifications..
Yes, PR files are required to check
 

iNeoEon

New member
Joined
Jul 3, 2022
Messages
1
Motherboard
Apple A1186
CPU
2x Intel Xeon X5482 @3.2GHz
Graphics
ASUS NVIDIA GTX 780 6GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hello guys.
Thank you for this guide.
I own a real Mac Pro 3,1 running Big Sur 11.6.6 on OpenCore legacy 0.4.7 configuration. It seems my OC config.plist file has no Thunderbolt support configuration whatsoever.
My Titan Ridge 2 has been flashed and has always worked flawlessly since I had High Sierra Installed on my system It still works under Big Sur although it needs a cold reboot to see TB3 attached device (a second warm reboot in case I have a second TB3 device attached).

I need to enable TB3 hot plug and hot swap. I see that there are some inconsistencies regarding ACPI paths between an Hackintosh and a real Mac i.e. my ACPI path is no RP21 rather P090, I always see this PXSX regarding Hackintosh while inside Hackintool usb tab I have a usb 3.2 pcie card shown on PXS3.

Now, I am not much of coder and surely no patcher guy, I just need to know if this guide of yours can be used on a Mac Pro 3,1 too or not.

Thank you!
Simo
 

Forum statistics

Threads
791
Messages
8,510
Members
7,994
Latest member
amedeus64