suizman

New member
Joined
Oct 30, 2022
Messages
5
Motherboard
MSI Z170A GAMING M5
CPU
Intel i7 6700K
Graphics
Intel HD Graphics 530
OS X/macOS
13.x
Bootloader
  1. Clover (UEFI)
  2. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Your profile is incomplete. Fill your profile first.
Done.
Btw, I forgot to ask if I have to copy any kext to /S/L/E(old skylake Intel) in addition or it works only with the Kaby Lake which are already included?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Done.
Btw, I forgot to ask if I have to copy any kext to /S/L/E(old skylake Intel) in addition or it works only with the Kaby Lake which are already included?
No, you don't need to copy any such kexts.

Provide the PR files as described in the FAQ:
 

suizman

New member
Joined
Oct 30, 2022
Messages
5
Motherboard
MSI Z170A GAMING M5
CPU
Intel i7 6700K
Graphics
Intel HD Graphics 530
OS X/macOS
13.x
Bootloader
  1. Clover (UEFI)
  2. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Here we go
 

Attachments

  • EFI-suizman.zip
    5.7 MB · Views: 8
  • PR.zip
    39.1 KB · Views: 4

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Here we go
Your configuration is not as per the guide.

As the Clover guide is not up to date, I would recommend you switching to OpenCore.

Read here:
 

suizman

New member
Joined
Oct 30, 2022
Messages
5
Motherboard
MSI Z170A GAMING M5
CPU
Intel i7 6700K
Graphics
Intel HD Graphics 530
OS X/macOS
13.x
Bootloader
  1. Clover (UEFI)
  2. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks, I've switched to OC and now the driver is loading. But I'm facing other issue 😢
I'm unable to get 1440p to work over HDMI. It's wired because it seams that the OC boot screen is actually running 1440p but when the system finish booting the maximum available resolution is 1080p in the display settings.
I'm using enable-max-pixel-clock-override and max-pixel-clock-frequency properties.
I've already tried to manually generate the EDID but get the same result.
 

Attachments

  • EFI-suizman.zip
    5.3 MB · Views: 5

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Thanks, I've switched to OC and now the driver is loading. But I'm facing other issue 😢
I'm unable to get 1440p to work over HDMI. It's wired because it seams that the OC boot screen is actually running 1440p but when the system finish booting the maximum available resolution is 1080p in the display settings.
I'm using enable-max-pixel-clock-override and max-pixel-clock-frequency properties.
I've already tried to manually generate the EDID but get the same result.
Just switching to OpenCore isn't sufficient. You clearly did not followed the guide properly.

Start here:
 

suizman

New member
Joined
Oct 30, 2022
Messages
5
Motherboard
MSI Z170A GAMING M5
CPU
Intel i7 6700K
Graphics
Intel HD Graphics 530
OS X/macOS
13.x
Bootloader
  1. Clover (UEFI)
  2. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi, I've managed to make it work with OC. Now I have the iGPU working and also I'm able to get 1440p output with the HDMI.

The problem was that I was using framebuffer-patch-enable, framebuffer-stolenmem, framebuffer-fbmem and also that my monitor is 240HZ with FreeSync and I have to force it to run at 144 which is the maximum for HDMI at 2K.

This is my working config for Skylake. Sure I need to improve it to make the USB3 work and all that stuff, but at least now I have a properly working desktop environment.

Many thanks!
 

Attachments

  • EFI-Skylake-iGPU-UHD.zip
    5.3 MB · Views: 18
  • Like
Reactions: EliteMacx86

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi, I've managed to make it work with OC. Now I have the iGPU working and also I'm able to get 1440p output with the HDMI.

The problem was that I was using framebuffer-patch-enable, framebuffer-stolenmem, framebuffer-fbmem and also that my monitor is 240HZ with FreeSync and I have to force it to run at 144 which is the maximum for HDMI at 2K.

This is my working config for Skylake. Sure I need to improve it to make the USB3 work and all that stuff, but at least now I have a properly working desktop environment.

Many thanks!
Great!
 

mj86

New member
Joined
Oct 25, 2022
Messages
1
Motherboard
Skylake
CPU
Custom
Graphics
Intel HD 530
OS X/macOS
13.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. Other
This guide helped me a lot. Thank you so much!!
 
  • Like
Reactions: EliteMacx86

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
4,147
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

Forum statistics

Threads
791
Messages
8,510
Members
7,994
Latest member
amedeus64