• Become a Premium Member for $25/year with no ads to improve your community experience.

i have 3 output ports for iGPU respectively: con0, con1, con2

View attachment 5883
Because of this, config framebuffer-portcount: 3
View attachment 5885

con0 is the port screen of my laptop because I see display0 inside it
View attachment 5884
Then I just config con1 and con2 to HDMI like that
View attachment 5886

And my port HDMI is 2.0 and my chipset is CFL, I need use LSPCON
View attachment 5887

--Summary my config about iGPU:
View attachment 5888


Do you think I'm wrong at any point?
Provide the ports picture of your Laptop
 
I really don't know which port to put LSPCON is 0, 1 or 2
 
So, a total of three connectors.

con0 - Internal Display
con1 - Type-C
con2 - HDMI

However, you'll need to check if either of these connector respond and whether you can get the display from them. Define all these three connectors in the DeviceProperties and set the appropriate connector as described in the guide. If you have done it already and getting no display via both ports, provide a copy of your config.plist.
 
My config after patching con1 and con2, and HDMI connect not working
Do you think I need patch busID for con1 and con2 ?
 

Attachments

  • config.plist.zip
    6.3 KB · Views: 5
My config after patching con1 and con2, and HDMI connect not working
Do you think I need patch busID for con1 and con2 ?
It's still not correct. con0 is missing. con1 should be set to DP not HDMI. Remove portcount. Portcount should be only added after the connectors are tested and verified.
 
Do you think I need patch busID for con1 and con2 ?
It's still not correct. con0 is missing. con1 should be set to DP not HDMI. Remove portcount. Portcount should be only added after the connectors are tested and verified.
But con0 is internal display, should I set what configure for that ?
 
Do you think I need patch busID for con1 and con2 ?
Yes, if you get no display.

But con0 is internal display, should I set what configure for that ?
That does not matter. It's a wrong theory that the port which doesn't work, you need to patch connectors for that. One should patch all the physical connectors used for display outputs, including internal.
 
Yes, if you get no display.


That does not matter. It's a wrong theory that the port which doesn't work, you need to patch connectors for that. One should patch all the physical connectors used for display outputs, including internal.
Do should I set what type for con1, still LDVS or other type ?
 

Forum statistics

Threads
1,574
Messages
14,805
Members
22,541
Latest member
barrera_marquez