How to Activate Thunderbolt Bus on Alpine Ridge without Flashing Custom Firmware

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,314
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

BerndVP

Member
Joined
Feb 25, 2021
Messages
30
Motherboard
X299X-Designare-10G-F3e
CPU
i9-10980XE
Graphics
AMD Pro WX 7100
OS X/macOS
10.15.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
So, you got this working on Alpine Ridge? Do you think you will get it working on Titan Ridge as well?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,314
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
So, you got this working on Alpine Ridge? Do you think you will get it working on Titan Ridge as well?
Yes, but it's not same for every motherboard. The guide will be up soon. It just eliminates the process of flashing a custom firmware and the only advantage is you can use the Thunderbolt on any supported OS. On Titan Ridge, it might be possible but currently, involved in other projects.
 

graffy

New member
Joined
Jan 5, 2022
Messages
6
Motherboard
Asus prime Z390-A + Asus ThunderboltEX 3 (nvm26)
CPU
Intel core i5 9400F
Graphics
AMD RX 560 4go
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mac
  1. iMac
Mobile Phone
  1. Android

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,314
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

graffy

New member
Joined
Jan 5, 2022
Messages
6
Motherboard
Asus prime Z390-A + Asus ThunderboltEX 3 (nvm26)
CPU
Intel core i5 9400F
Graphics
AMD RX 560 4go
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mac
  1. iMac
Mobile Phone
  1. Android
Ok so I'll let you know my experience with the clover/EFI files for Catalina up to date

My setup:
- Asus prime Z390-A
- Asus thunderboltEX 3 (nvm26) one port
- Intel i9 9900k
- Asus Rog Strix RX570 4Go
- 32Go Corsair (4x8)
- Antelope discrete 8 synergy core

My Asus thunderbolt card is not flashed and works with the original bios which version NVM26.
I had tried to flash this one but it didn't work.
If you tell me how I can recover the firmware save on the USB key CH341a to communicate it to you?

Otherwise for the configuration it is important not to forget to generate a ROM in config.plist/Rt variables - SMBIOS otherwise the Antelope card will be recognized but not connected in the launcher and therefore not active!.
I left my config.plist, I only erased my serial and ROM numbers (generate your own) , I left the UUID for the nvram.

All Work :

- Thunderbolt and Hotplug
- UHD 630
- Radeon RX570
- sleep and wake up
- Sidecar (via Ipad)
- NVRAM
- Ethernet
 

Attachments

  • EFI.zip
    4.2 MB · Views: 29
  • IMG_20220307_110120_copy_1587x1190.jpg
    IMG_20220307_110120_copy_1587x1190.jpg
    314.9 KB · Views: 36
  • IMG_20220307_110139_copy_1587x1190.jpg
    IMG_20220307_110139_copy_1587x1190.jpg
    275.1 KB · Views: 29
  • IMG_20220307_110152_copy_1587x1190.jpg
    IMG_20220307_110152_copy_1587x1190.jpg
    239.4 KB · Views: 27
  • IMG_20220307_110200_copy_992x744.jpg
    IMG_20220307_110200_copy_992x744.jpg
    105 KB · Views: 31
  • IMG_20220307_110243_copy_992x744.jpg
    IMG_20220307_110243_copy_992x744.jpg
    134.9 KB · Views: 28
  • IMG_20220307_110300_copy_992x744.jpg
    IMG_20220307_110300_copy_992x744.jpg
    123.5 KB · Views: 29
  • IMG_20220307_110321_copy_992x744.jpg
    IMG_20220307_110321_copy_992x744.jpg
    117.7 KB · Views: 26
  • IMG_20220307_110309_copy_992x744.jpg
    IMG_20220307_110309_copy_992x744.jpg
    93.3 KB · Views: 28
  • IMG_20220307_110341_copy_992x744.jpg
    IMG_20220307_110341_copy_992x744.jpg
    132.3 KB · Views: 28
  • IMG_20220307_110351_copy_992x744.jpg
    IMG_20220307_110351_copy_992x744.jpg
    99.3 KB · Views: 29
  • IMG_20220307_110410_copy_992x744_1.jpg
    IMG_20220307_110410_copy_992x744_1.jpg
    130.7 KB · Views: 33
  • CF002FA7-6E03-4A7F-818A-1792FB11673A.jpeg
    CF002FA7-6E03-4A7F-818A-1792FB11673A.jpeg
    507.4 KB · Views: 35
  • FE8BB7B9-B7C0-4503-AAC6-B6D950790DC5.jpeg
    FE8BB7B9-B7C0-4503-AAC6-B6D950790DC5.jpeg
    354.7 KB · Views: 34
Last edited:
  • Like
Reactions: EliteMacx86

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,314
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Ok so I'll let you know my experience with the clover/EFI files for Catalina up to date

My setup:
- Asus prime Z390-A
- Asus thunderboltEX 3 (nvm26) one port
- Intel i9 9900k
- Asus Rog Strix RX570 4Go
- 32Go Corsair (4x8)
- Antelope discrete 8 synergy core

My Asus thunderbolt card is not flashed and works with the original bios which version NVM26.
I had tried to flash this one but it didn't work.
If you tell me how I can recover the firmware save on the USB key CH341a to communicate it to you?

Otherwise for the configuration it is important not to forget to generate a ROM in config.plist/Rt variables - SMBIOS otherwise the Antelope card will be recognized but not connected in the launcher and therefore not active!.
I left my config.plist, I only erased my serial and ROM numbers (generate your own) , I left the UUID for the nvram.

All Work :

- Thunderbolt and Hotplug
- UHD 630
- Radeon RX570
- sleep and wake up
- Sidecar (via Ipad)
- NVRAM
- Ethernet
What's the current issue with Thunderbolt?

Also, IOReg is missing.
 

graffy

New member
Joined
Jan 5, 2022
Messages
6
Motherboard
Asus prime Z390-A + Asus ThunderboltEX 3 (nvm26)
CPU
Intel core i5 9400F
Graphics
AMD RX 560 4go
OS X/macOS
10.15.x
Bootloader
  1. Clover (UEFI)
Mac
  1. iMac
Mobile Phone
  1. Android
Oh sorry..
What's the current issue with Thunderbolt?

Also, IOReg is missing.
All work.. I have only discrete antelope 8 SC as thunderbolt device and it works perfectly
Ipad work via USB port (Sidecar)

** It also works under W10 without changing anything in the bios, just boot to the W10 disk.
 

Attachments

  • io2022.zip
    831.1 KB · Views: 26
Last edited:
  • Like
Reactions: EliteMacx86

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,314
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Oh sorry..

I have only discrete antelope 8 SC as thunderbolt device and it works perfectly
Ipad work via USB port (Sidecar)
So, I believe, this is a success report?

As per your IOReg, Bus activation is not present. As indicated in the original thread, a bus is not even required for Antelope Interfaces. Although, activating Bus has a different need.

To report your success, see the thread below.

I'll add it to the table. Feel free to provide screenshots and other details, info you might have in the above thread.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,314
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I had tried to flash this one but it didn't work.
If you tell me how I can recover the firmware save on the USB key CH341a to communicate it to you?
For this, have a look here:
 

Forum statistics

Threads
632
Messages
6,861
Members
5,587
Latest member
alexcorpse