Hardware acceleration not full intel HD 620

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,611
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I think i expressed myself badly. I can modify brightness with the keyboard keys, macOS detect the internal screen but there is no display at all on the internal screen, it still black…
Set Con0 type to 00040000 and provide your complete PR files.
 

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
Set Con0 type to 00040000 and provide your complete PR files.
Okay i have set it to 00040000 but nothing changed.
Here are the PR files.
 

Attachments

  • PR files.zip
    21.9 MB · Views: 45

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,611
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Okay i have set it to 00040000 but nothing changed.
Here are the PR files.
Replace the Device Properties for IGPU with the following. Use any text editor.

XML:
<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>AAPL,ig-platform-id</key>
                <data>AAAbWQ==</data>
                <key>enable-hdmi20</key>
                <data>AQAAAA==</data>
                <key>enable-lspcon-support</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-busid</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-con1-alldata</key>
                <data>AQUKAAAIAACHAQAAAgQKAAAIAACHAQAA/wAAAAEAAAAgAAAA</data>
                <key>framebuffer-con1-busid</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-con2-alldata</key>
                <data>AQUKAAAIAACHAQAAAwYKAAAEAACHAQAA/wAAAAEAAAAgAAAA</data>
                <key>framebuffer-con2-busid</key>
                <data>BAAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-fbmem</key>
                <data>AACQAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-portcount</key>
                <data>BAAAAA==</data>
                <key>framebuffer-stolenmem</key>
                <data>AAAwAQ==</data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

If HDMI doesn't works, ignore for now. Reply with new PR files.
 

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
Replace the Device Properties for IGPU with the following. Use any text editor.

XML:
<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>AAPL,ig-platform-id</key>
                <data>AAAbWQ==</data>
                <key>enable-hdmi20</key>
                <data>AQAAAA==</data>
                <key>enable-lspcon-support</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-busid</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-con1-alldata</key>
                <data>AQUKAAAIAACHAQAAAgQKAAAIAACHAQAA/wAAAAEAAAAgAAAA</data>
                <key>framebuffer-con1-busid</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-con2-alldata</key>
                <data>AQUKAAAIAACHAQAAAwYKAAAEAACHAQAA/wAAAAEAAAAgAAAA</data>
                <key>framebuffer-con2-busid</key>
                <data>BAAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-fbmem</key>
                <data>AACQAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-portcount</key>
                <data>BAAAAA==</data>
                <key>framebuffer-stolenmem</key>
                <data>AAAwAQ==</data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

If HDMI doesn't works, ignore for now. Reply with new PR files.
I have to use Skylake laptop ig-platform-id and device-id otherwise internal screen is still black.
There's no HDMI at all.
 

Attachments

  • PR Files.zip
    21.8 MB · Views: 44

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,611
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have to use Skylake laptop ig-platform-id and device-id otherwise internal screen is still black.
There's no HDMI at all.
Are you sure you have Kaby Lake CPU?
 

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
Are you sure you have Kaby Lake CPU?
It is an i3 7020U with intel 620, yes I'm sure :)

I've tried many device-properties, and it is ig-platform-id which causes troubles :
With only these properties :

- ig-platform-id = 59160000
- device-id = 59160000
-> internal screen works, but 5Mb VRAM, hdmi and brightness don't work

- ig-platform-id = 00001619
- device-id = 16190000
-> internal screen, hdmi work, 1536 Mb VRAM but no HDMI audio and there are glitches, dock not translucent (not full QE/CI)
 

Attachments

  • Files.zip
    7.2 MB · Views: 42

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,611
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
It is an i3 7020U with intel 620, yes I'm sure :)

I've tried many device-properties, and it is ig-platform-id which causes troubles :
With only these properties :

- ig-platform-id = 59160000
- device-id = 59160000
-> internal screen works, but 5Mb VRAM, hdmi and brightness don't work

- ig-platform-id = 00001619
- device-id = 16190000
-> internal screen, hdmi work, 1536 Mb VRAM but no HDMI audio and there are glitches, dock not translucent (not full QE/CI)
All these IDs are related to Desktop, not Laptops. The first priority should be to get the internal screen working, not the HDMI.

Incomplete PR files attached. EFI is missing.
 

Trending Threads

Forum statistics

Threads
714
Messages
7,408
Members
6,228
Latest member
andyjusa