Hardware acceleration not full intel HD 620

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi everyone !

I am facing with a problem with Monterey 12.1 with OpenCore 0.7.5.
I have successfully install it but I have glitches on the internal screen, the dock isn't translucent like QE/CI is not fully activated.
I have no HDMI Audio too...
I have tried many patches, tests but nothing worked, can you help me ?

I attached my config.plist and a screenshot, I think I have trouble with device-properties.
 

Attachments

  • Files.zip
    707.9 KB · Views: 50

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,908
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi everyone !

I am facing with a problem with Monterey 12.1 with OpenCore 0.7.5.
I have successfully install it but I have glitches on the internal screen, the dock isn't translucent like QE/CI is not fully activated.
I have no HDMI Audio too...
I have tried many patches, tests but nothing worked, can you help me ?

I attached my config.plist and a screenshot, I think I have trouble with device-properties.
Incomplete PR files attached.

IOReg, Kextcache Output and EFI folder is missing. Also, are you sure that your screen resolution is 1600x900? It should be probably between 1366x768 or 1920x1080, unless its 4K/UHD/QHD.
 

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
Oh yes I forgot these. I attached them.
Yes I am sure that it is the max resolution for this laptop, you can check on the screenshot.
 

Attachments

  • Additionnal files.zip
    22 MB · Views: 45

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,908
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Oh yes I forgot these. I attached them.
Yes I am sure that it is the max resolution for this laptop, you can check on the screenshot.
As per the files, the VRAM is working. Although, the platform ID you injected is for Desktops. For Laptops, the ideal Platform ID would be 00001B59
 

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
I tried 2 patches :
- replaced 00001619 with 00001B59 -> No HDMI, no internal screen and brightness doesn't work

- try another device-properties with 00001B59 -> graphics works perfectly, HDMI Audio works, brightness works but internal screen still black.

I attached IOReg and a screenshot of the new device-properties.
 

Attachments

  • new patch 00001B59.zip
    7.3 MB · Views: 42

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,908
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I tried 2 patches :
- replaced 00001619 with 00001B59 -> No HDMI, no internal screen and brightness doesn't work

- try another device-properties with 00001B59 -> graphics works perfectly, HDMI Audio works, brightness works but internal screen still black.

I attached IOReg and a screenshot of the new device-properties.
You shouldn't need Device ID.

Read here:
 

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
Okay, i have followed the guide and replaced the device-properties from the guide.
First attempt -> internal screen black but brightness works. No HDMI...

Second attempt -> modified some properties and everything work, except internal screen which is still black...
Attached IOReg...
 

Attachments

  • files.zip
    7.3 MB · Views: 44

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,908
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Okay, i have followed the guide and replaced the device-properties from the guide.
First attempt -> internal screen black but brightness works. No HDMI...

Second attempt -> modified some properties and everything work, except internal screen which is still black...
Attached IOReg...
Add igfxonln=1 to your boot args and then check.
 

Lucpop2007!

New member
Joined
Jan 12, 2022
Messages
10
Motherboard
HP laptop 17-by0006nf
CPU
i3 7020u 2.3 GHz
Graphics
Intel HD 620 (1600x900)
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mac
  1. iMac
Mobile Phone
  1. iOS
It didn’t changed anything.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,908
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

Forum statistics

Threads
753
Messages
8,027
Members
6,948
Latest member
Northwinds