Dual Thunderbolt 3 [X299X Designare 10G]

BerndVP

Member
Joined
Feb 25, 2021
Messages
30
Motherboard
X299X-Designare-10G-F3e
CPU
i9-10980XE
Graphics
AMD Pro WX 7100
OS X/macOS
10.15.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
So,
I'm using the internal TB3 of the board to run an Sonnet Echo Express 3 with Avid HDX Card
And a CalDigit TS3-Plus.

Connection is:
- TB3 Port to Sonnet EX3 - To TS3+

I'm using the Displayport of the TS3+ to run a display.

Using 1 TB3 port for EX3 and one for TS3+ doesn't work, always one of the two TB3 devices won't connect to it's drivers.

The internsal TB3 isn't flashed with a custom firmware, because it just works fine with my devices.


So I have a Gigabyte Titan Ridge 2.0 with NVM 50 flashed.
I put it in the system with the correct SSDT for it an it's perfect recognized in MacOS.

But cold booting the system with the Sonnet EX3 connected to the Titan Ridge and the TS3+ to Internal TB3:
TS3+ working fine, EX3 doesn't light up.

So, I feel like I have to do a warm reboot everytime, is there a way to force start the Titan Ridge Card on Cold boot ?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,419
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
So,
I'm using the internal TB3 of the board to run an Sonnet Echo Express 3 with Avid HDX Card
And a CalDigit TS3-Plus.

Connection is:
- TB3 Port to Sonnet EX3 - To TS3+

I'm using the Displayport of the TS3+ to run a display.

Using 1 TB3 port for EX3 and one for TS3+ doesn't work, always one of the two TB3 devices won't connect to it's drivers.

The internsal TB3 isn't flashed with a custom firmware, because it just works fine with my devices.
When you tend to utilize additional TB features, it should be noted that you need to have a flashed custom firmware, regardless of the onboard TB chip or a PCIe one.

So I have a Gigabyte Titan Ridge 2.0 with NVM 50 flashed.
I put it in the system with the correct SSDT for it an it's perfect recognized in MacOS.

But cold booting the system with the Sonnet EX3 connected to the Titan Ridge and the TS3+ to Internal TB3:
TS3+ working fine, EX3 doesn't light up.

So, I feel like I have to do a warm reboot everytime, is there a way to force start the Titan Ridge Card on Cold boot ?
Recently, in our active TB project, we have got 100% TB implementation with each and every feature, including HotPlug which supports pure Cold Boot, Sleep, Dock, Type-C, and eGPUs. This implementation is completely identical to a real Mac including the behavior. We'll soon release a demonstration video on our Official YT channel.

In our previous work, we got to work 3xThunderbolt 3 Card, featuring 6 Thunderbolt 3 ports with every function, including sleep and booting in cold boot mode.

Looks like you forgot to attach your PR files.
 

BerndVP

Member
Joined
Feb 25, 2021
Messages
30
Motherboard
X299X-Designare-10G-F3e
CPU
i9-10980XE
Graphics
AMD Pro WX 7100
OS X/macOS
10.15.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
So, you're telling me to flash the internal TB3 chip and make that one BUS-1 ?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,419
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
So, you're telling me to flash the internal TB3 chip and make that one BUS-1 ?
Yes, when you need to utilize Docks and Adapters, it makes more sense to flash the onboard TB chip with custom firmware.
 

BerndVP

Member
Joined
Feb 25, 2021
Messages
30
Motherboard
X299X-Designare-10G-F3e
CPU
i9-10980XE
Graphics
AMD Pro WX 7100
OS X/macOS
10.15.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
ok, what firmware do I need to flash it ?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,419
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
ok, what firmware do I need to flash it ?
Read here:

As per the guide, you should flash NVM33.
 

Forum statistics

Threads
673
Messages
7,046
Members
5,890
Latest member
haggar12