Dell Inspiron N5110: no internal mic after wake (High Sierra)

ita266

New member
Joined
Mar 14, 2021
Motherboard
Dell Inspiron N5110
CPU
i3-2330m
Graphics
Intel HD3000
OS X/macOS
10.13.x
Bootloader
  1. Clover (Legacy)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi everyone. I'm trying to make a hackintosh on a Dell Inspiron 5110. Bios A11 (not UEFI). Installed High Sierra on SSD in GPT mode (2nd drive in caddy bay). Succesfully installed and booting from USB stick (Windows MBR on HDD #1 and High Sierra GPT on drive #2). Everything works (usb, power management, sleep, wake) but after wake internal mic doesn't work (with boot arg alcid=12). If I use alcid=13 no problem with internal mic but no way to use external jack (headphones and mic). Brightness and FN keys also are a minor issues. Thanks
 

Attachments

  • debug_19481.zip
    3.1 MB · Views: 37

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi everyone. I'm trying to make a hackintosh on a Dell Inspiron 5110. Bios A11 (not UEFI). Installed High Sierra on SSD in GPT mode (2nd drive in caddy bay). Succesfully installed and booting from USB stick (Windows MBR on HDD #1 and High Sierra GPT on drive #2). Everything works (usb, power management, sleep, wake) but after wake internal mic doesn't work (with boot arg alcid=12). If I use alcid=13 no problem with internal mic but no way to use external jack (headphones and mic). Brightness and FN keys also are a minor issues. Thanks
Have you checked using Codec Commander?
 

ita266

New member
Joined
Mar 14, 2021
Motherboard
Dell Inspiron N5110
CPU
i3-2330m
Graphics
Intel HD3000
OS X/macOS
10.13.x
Bootloader
  1. Clover (Legacy)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Have you checked using Codec Commander?
Codeccommander is correctly loaded by the system (as reported in kextcache output attached in my post), but it doesn't solve the issue :(
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Codeccommander is correctly loaded by the system (as reported in kextcache output attached in my post), but it doesn't solve the issue :(
The configuration is not as per the guide.

You must use one location for the kexts. Either L/E or S/L/E or ESP, never mixed.

What's your Audio Codec?

ResetHDA is not checked.
For Laptops, it's mandatory to patch the ACPI. For more information on ACPI patching, check the thread linked below.
 

ita266

New member
Joined
Mar 14, 2021
Motherboard
Dell Inspiron N5110
CPU
i3-2330m
Graphics
Intel HD3000
OS X/macOS
10.13.x
Bootloader
  1. Clover (Legacy)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
The configuration is not as per the guide.

You must use one location for the kexts. Either L/E or S/L/E or ESP, never mixed.

What's your Audio Codec?

ResetHDA is not checked.
For Laptops, it's mandatory to patch the ACPI. For more information on ACPI patching, check the thread linked below.
I thought the option "inject kexts=detect" was ok to address clover where to find them. So do I have to remove all the kexts from esp but VirtualSMC?
My audio device is idt 92hd87b1/3.
I thought AppleAlc and bootarg were enough for audio patching, also because I'd like to use clover hotpatching instead of partial hotpatching or full dsdt patching.
Maybe could you help me in dsdt audio patching?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I thought the option "inject kexts=detect" was ok to address clover where to find them. So do I have to remove all the kexts from esp but VirtualSMC?
It must be set to YES. Remove all installed kexts from L/E and S/L/E and move the mandatory kexts to ESP. For more information, refer to the thread linked below.
My audio device is idt 92hd87b1/3.
Layout ID 12 is the recommended one.
I thought AppleAlc and bootarg were enough for audio patching, also because I'd like to use clover hotpatching instead of partial hotpatching or full dsdt patching.
For Laptops, ACPI patching is mandatory.
Maybe could you help me in dsdt audio patching?
Just patching DSDT for Audio will make it working. You'll need to fully patch the DSDT, if not going for the complete set.

Read here:
 

ita266

New member
Joined
Mar 14, 2021
Motherboard
Dell Inspiron N5110
CPU
i3-2330m
Graphics
Intel HD3000
OS X/macOS
10.13.x
Bootloader
  1. Clover (Legacy)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
It must be set to YES. Remove all installed kexts from L/E and S/L/E and move the mandatory kexts to ESP. For more information, refer to the thread linked below.

Layout ID 12 is the recommended one.

For Laptops, ACPI patching is mandatory.

Just patching DSDT for Audio will make it working. You'll need to fully patch the DSDT, if not going for the complete set.

Read here:
So is it enough to patch the DSDT audio section, put the new dsdt in acpi/patched and leave the clover acpi patches as they are?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
So is it enough to patch the DSDT audio section, put the new dsdt in acpi/patched and leave the clover acpi patches as they are?
You'll need to fully patch the DSDT which also includes Audio part.
 

ita266

New member
Joined
Mar 14, 2021
Motherboard
Dell Inspiron N5110
CPU
i3-2330m
Graphics
Intel HD3000
OS X/macOS
10.13.x
Bootloader
  1. Clover (Legacy)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Ok thank you very much.. I'll try to do it, even if that method changes everything about my lazy thought of patching :)
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Ok thank you very much.. I'll try to do it, even if that method changes everything about my lazy thought of patching :)
You're welcome.
 

Forum statistics

Threads
503
Messages
4,676
Members
4,254
Latest member
nova7foldism