AppleALC Earphone mic not working

Pranay

Member
Joined
Dec 28, 2021
Messages
101
Motherboard
Hp elitebook 840 g1 motherboard
CPU
Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz 2.50 GHz
Graphics
Intel HD 4400 Graphics
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. iOS
Hey Team EliteMacX86 I wanted to use my Earphone microphone as my manditory as my inbuilt microphone is not so good quality but the problem is I use Lates AppleALC kext and it is not showing me my extrernal microphone only internal is been shown is there any fix?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,419
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey Team EliteMacX86 I wanted to use my Earphone microphone as my manditory as my inbuilt microphone is not so good quality but the problem is I use Lates AppleALC kext and it is not showing me my extrernal microphone only internal is been shown is there any fix?
What's your Codec?
 

Pranay

Member
Joined
Dec 28, 2021
Messages
101
Motherboard
Hp elitebook 840 g1 motherboard
CPU
Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz 2.50 GHz
Graphics
Intel HD 4400 Graphics
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. iOS
What's your Codec?
Screenshot 2022-04-08 at 6.32.29 PM.png
 

Pranay

Member
Joined
Dec 28, 2021
Messages
101
Motherboard
Hp elitebook 840 g1 motherboard
CPU
Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz 2.50 GHz
Graphics
Intel HD 4400 Graphics
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. iOS
Layout ID seems to be correct. Maybe you can try with another Headphone?
It seems to be a problem with My AppleALC I am not sure cause before I was using a brebuilt EFI for my laptop which's AppleALC's external micrphone was working but the mic would stop to work after about 30 sec so I created a Freshly new EFI and took the latest AppleALC and then the external micrphone is not showing up in SystemPreferences .I tried my sony headphones and it didn't work.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,419
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
It seems to be a problem with My AppleALC I am not sure cause before I was using a brebuilt EFI for my laptop which's AppleALC's external micrphone was working but the mic would stop to work after about 30 sec so I created a Freshly new EFI and took the latest AppleALC and then the external micrphone is not showing up in SystemPreferences .I tried my sony headphones and it didn't work.
No PR files attached.
 

Pranay

Member
Joined
Dec 28, 2021
Messages
101
Motherboard
Hp elitebook 840 g1 motherboard
CPU
Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz 2.50 GHz
Graphics
Intel HD 4400 Graphics
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. iOS

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,419
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

Pranay

Member
Joined
Dec 28, 2021
Messages
101
Motherboard
Hp elitebook 840 g1 motherboard
CPU
Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz 2.50 GHz
Graphics
Intel HD 4400 Graphics
OS X/macOS
12.0.x
Bootloader
  1. OpenCore
Mobile Phone
  1. iOS

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
3,419
Motherboard
Supermicro X11SPA-T
CPU
Intel Xeon W-3275 28 Core
Graphics
2xAMD RX 580 8GB
OS X/macOS
11.0.x
Bootloader
  1. OpenCore
Mac
  1. Mac mini
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
What else do u need ?
- IOReg
- Kextcache output
- Hackintool PCIe Report
- System Report
- System Preferences>Sound>Input and Output screenshots
- Old EFI where you had the Headphones working
- Original ACPI files
 
Similar threads
Thread starter Title Forum Replies Date
ishvnu Mic working Speaker not working Catalina 10.15.4 Audio 5
M Mic Input Level Problem! Audio 9

Similar threads

Forum statistics

Threads
673
Messages
7,046
Members
5,890
Latest member
haggar12