• Become a Premium Member for $25/year with no ads to improve your community experience.

A lot of app doesn't work

Z2VvZ2Vv

New member
Joined
Jul 24, 2022
Messages
21
Motherboard
Acer Veriton X2631G i5 4460
CPU
i5 4460
Graphics
GT 1030
OS X/macOS
13.x
Bootloader
  1. OpenCore (UEFI)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I recently installed my hackintosh and all works fine except button "ok" in Plans, Chrome (not start just a white page) and Firefox (launch but freeze). Have you any ideas of the problem ? Also when I record my screen with "screenshot" the result is just a blue background and the cursor. It's related to that ? NB : Safari works fine.
Thanks.
 

Attachments

  • Enregistrement de l’écran 2022-07-25 à 11.18.11.mov
    163 KB
I recently installed my hackintosh and all works fine except button "ok" in Plans, Chrome (not start just a white page) and Firefox (launch but freeze). Have you any ideas of the problem ? Also when I record my screen with "screenshot" the result is just a blue background and the cursor. It's related to that ? NB : Safari works fine.
Thanks.
This could be a result of GT 1030 being used in Monterey. Note that only High Sierra supports Pascal GPUs. Since Mojave, there are no WebDrivers. As you have an IGPU compatible CPU, the solution is to use IGPU or upgrade to a different GPU that is supported on Monterey or you can also install High Sierra. Choose one according to your preference.

To confirm the issue, disable NVIDIA Drivers using nv_disable=1 in your boot args and then check if you can open Chrome and Firefox. If yes, you know the reason now.
 
I've tried the boot args and it's do nothing. I searched and i found the problem, it's the SIP (when it's disabled almost all application download on the web don't work, i don't know the reason but that's it). After knowing the problem i tried to disable the sip with kext of GT1030 and the boot args but macOS don't boot up. I think i will be finally use my Macbook because the app that i would have on macOS on desktop don't works.
 
I've tried the boot args and it's do nothing.
With the NVIDIA disabled, do you still have acceleration? Do Apps work?
I searched and i found the problem, it's the SIP (when it's disabled almost all application download on the web don't work, i don't know the reason but that's it).
SIP can be either enabled or disabled. What's your SIP status? White screen with SIP enabled or disabled cannot be an issue for sure as i have tested both of them at my end.
After knowing the problem i tried to disable the sip with kext of GT1030 and the boot args but macOS don't boot up.
Disabling SIP doesn't require any Kext involvement. With OpenCore, the SIP can be disabled in NVRAM>csr-active-config with a value of 67000000. Nothing more is required.
I think i will be finally use my Macbook because the app that i would have on macOS on desktop don't works.
Well, it is up to you.
 

Forum statistics

Threads
1,482
Messages
14,073
Members
21,255
Latest member
eraser268